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Chapter 1: About ArcSight Interactive
Discovery
ArcSight Interactive Discovery augments ArcSight Logger and ArcSight Enterprise Security
Management’s Pattern Discovery, dashboards, reports, and analytical graphics. Interactive Discovery
provides enhanced forensic data analysis and reporting capabilities using a comprehensive selection of
pre-built interactive statistical graphics.

Use Interactive Discovery to:

l Quickly gain insight into your complex security data

l Explore and drill down into security data with unprecedented control and flexibility

l Accelerate discovery of hard to find, suspicious events

l Present state of security in compelling visual summaries

l Build a persuasive, non-technical call to action

l Prove IT Security value and help justify budgets

How Interactive Discovery Works
With flat data in a table it is hard to tell which events are significant and how one may relate to another.
But Interactive Discovery can display data points in relation to each other in meaningful and business-
applicable ways, so that you can see that, for example, one attacker with many failed connections to
targets could indicate a port scan or a worm.
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Interactive Discovery visualizes data exported from reports and filters in the Logger and ESM Content
Packs. These reports provide the formatted event data for Interactive Discovery to visualize.

Interactive Discovery can also visualize data exported from ArcSight Logger using either search and
export or ArcSight Logger reports. The search queries and reports are provided in the ArcSight Logger
Interactive Discovery Content Pack.

ArcSight Interactive Discovery enables you to learn new things about your network security activity.
During daily human analysis of the past day's data, you may find new things that were missed by the
analyst. You can use this data to build new rules that improve your overall enterprise security
management process.

This guide describes the ArcSight project files. For information on using ArcSight Interactive Discovery,
use the online help system accessible from the user interface.

Audience
This guide is intended for ArcSight ESM or ArcSight Logger users who wish to use the advanced
analysis and graphics capabilities of Interactive Discovery.

To effectively use ArcSight Interactive Discovery, you should have knowledge of:

l Your network security architecture, protocols, and outputs

l Basic principles of data and statistical analysis

Project User's Guide
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Chapter 2: Installing Interactive Discovery
Before installing Interactive Discovery, first familiarize yourself with Interactive Discovery's deployment
architecture and evaluate the system requirements.

Installation Overview
ArcSight Interactive Discovery can be resource-intensive when operating on large files, so it is
recommended that you install it on its own host. If you have systems with large RAM capacities (2 or
more GB), you can deploy Interactive Discovery on the same system that hosts the ArcSight Console.

The installation consists of several parts, all contained in the downloaded HP_ArcSight_
Interactive_Discovery_6.4_AID.zip file.

l Install the program (32-bit or 64-bit) from the ZIP file onto the system that will run Interactive
Discovery.

l Extract the ArcSight Interactive Discovery project files directory onto the Interactive Discovery
system.

l Deploy the ArcSight_Interactive_Discovery.arb to the Manager.

l Import the Field Sets and deploy the reports to the Logger..

Run the installation on the Interactive Discovery system.
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Operations Overview
Place the Interactive Discovery project files with the file extension adv on the Interactive Discovery
system. These project files contain a data source reference to the CSV data file that you export from
ESM or Logger. The data itself is not contained in the ADV file, rather, the ADV file refers to the data in
the CSV file. When you open a project ADV file, it reads the data from the CSV file source.

The ArcSight Console is the host system for the ArcSight Focused Report and the CSV file it generates.
In Logger you generate a report and save it to a CSV file for import into AID. You can also use one of
the included fieldsets to perform a Logger search save it to a CSV file. Copy the CSV file to the
Interactive Discovery system.

If you share projects among users with different Interactive Discovery instances on different systems,
either send them the project file and the data source file, or provide users with a shared network
directory where the files are located on a central Interactive Discovery system.

The AID schema contains event fields that ArcSight considers to be the most common event fields to
evaluate for most security situations and reduces the data to process.

Note that a large schema (dozens of columns) and large return sets (millions of rows in a single query)
can cause a performance impact on ESM and Logger. To minimize this, ArcSight recommends that when
you create your search criteria, that you be as specific as your use case permits.
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What's in the Download
The Interactive Discovery download file is HP_ArcSight_Interactive_Discovery_6.4_AID.zip.
It contains a number of files, many of which the installer uses. When you unzip this file, the folder layout
is as shown here:

Content from these folders are used during installation:

l AID\Advizor: the AID installer, ArcSight Interactive Discovery Bundle.exe., in both 32-
bit and 64-bit files, as well as the Advizor Implementation Guide and release notes.

l AID\Content\ESM: the ESM content pack, sample data, and project files. Do not change these
files in any way.

l AID\Content\Logger : the ArcSight Logger content pack, sample data, and project files. Do not
change these files in any way.

l AID\HP_Data_Analysis\ESM (and \Logger) these are working copies of the files in the
AID\Content folder . This is your work area.

The AID\Content\ESM folder contains the following files:

File Description

AID_Schema.csv The project ArcSight_AID_Schema.adv uses this file as its data source. As delivered this is a
sample data file that contains the AID schema of data output. After installation, you can use it to test
the functions of ArcSight Interactive Discovery.

Later, when you generate real CSV data files, you can save them with different names. ADV projects
allow you to select different CSV data source files and then you can save your projects with different
names for different CSV files.

AID_Schema.ini The INI file that contains initialization settings for the CSV data source file of the same name.

This file name must match the name of the CSV file your ADV file uses, so if you rename or create a
new CSV file, rename or create a copy of an INI file for it.

Place the INI file in the same folder as its CSV file.

ArcSight_AID_
Schema.adv

An AID project file for ESM, that utilizes the AID_Schema (dataset) in Interactive Discovery

Project User's Guide
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File Description

ArcSight_AID_
Schema.backup

Backup of the corresponding file. Created automatically.

ArcSight_AID_
Schema_
Business_
Role.advm

Self-contained sample project file, used for familiarization with the product.

ArcSight_
Interactive_
Discovery.arb

You copy this ArcSight package file to the ESM Console, from which you import it to the
ESM Manager. The ARB file contains the reports, filters, and focused reports required to output data
for consumption by Interactive Discovery.

The content of the ARB is described in "ESM Focused Reports " on page 17.

PriorityByBin.asl Enables color sorting by ArcSight ESM Active Channel Priority.

The AID\Content\Logger folder contains the following files:

File Description

Logger_AID_
Schema.adv

An AID project file for Logger, that utilizes the AID_Schema (dataset) in Interactive Discovery

Logger_AID_
Schema.backup

Backup of the corresponding file. Created automatically.

Logger_AID_
Schema.advm

Included for demonstration scripts. Any .adv file can be imported and thenexported as .advm. The
data is NOT refreshed from the source unless the user forces it to do so. Additionally,the .advm file is
much smaller than the .adv and .csv combined, as it is compressed already.

Logger_AID_
Schema.csv

The project uses this file as its data source. As delivered this is a sample data file that contains the
AID_Schema of data output. After installation, you can use it to test the functions of ArcSight
Interactive Discovery.

Later, when you generate real CSV data files, you can save them with different names. ADV projects
allow you to select different CSV data source files and then you can save your projects with different
names for different CSV files.

Logger_AID_
Schema.ini

The INI file that contain initialization settings for the CSV data source file of the same name.

This file name must match the name of the CSV file your ADV file uses, so if you rename or create a
new CSV file, rename or create a copy of an INI file for it.

Place the INI file in the same folder as its CSV file.

Logger_AID_
Schema_
Report.csv

Sample file shipped with the product. Used by the Logger_AID_Schema.adv file provided. To use a
sample file, copy the file and rename it to match the corresponding default CSV file in the \AID\HP_
Data_Analysis\Logger subdirectory.

Logger_AID_
Schema_
Search.csv

Sample file shipped with the product. Used by the Logger_AID_Schema.adv file provided. To use a
sample file, copy the file and rename it to match the corresponding default CSV file in the \AID\HP_
Data_Analysis\Logger subdirectory.

Project User's Guide
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File Description

Logger_AID_
Schema_
SearchExport.csv

Sample file shipped with the product. Used by the Logger_AID_Schema.adv file provided. To use a
sample file, copy the file and rename it to match the corresponding default CSV file in the

\AID\HP_Data_Analysis\Logger subdirectory.

Later, when you generate real CSV data files, you can save them with different names. ADV projects
allow you to select different CSV data source files and then you can save your projects with different
names for different CSV files.

Logger_
Fieldset__AID_
Schema.xml.gz

Import this fieldset into Logger. You can use them to run a search for the AID_Schema data sets and
export those event fields to a .csv for use by the provided ArcSight Interactive Discovery projects.

Logger_Report_
AID_Schema.cab

You deploy the report bundle to the Logger machine. The CAB file contains an AID_Schema report
required to output data for consumption by Interactive Discovery.

PriorityByBin.asl Enables color sorting by ArcSight ESM Active Channel Priority.

System Requirements
Interactive Discovery can only be installed on Windows operating systems. For system requirements
recommended for optimum performance, see the Advizor Implementation Guide included in the ZIP file
download.

ESM Recommendations: In addition, these recommendations are made for best performance for
ESM. These recommendations do not apply to Logger.

l 16 GB heap size

l Reports archived in separate process.

16 GB Heap Size

For high performance systems, 16 GB heap size is recommended. To change the heap size:

1. Stop ESM Manager.

2. Update the file server.wrapper.conf with these lines:

wrapper.java.initmemory=16384

wrapper.java.maxmemory=16384

3. Start the manager for the changes to take effect.
AID Reports Separate Process

To ease the load on the Manager, AID reports should be archived in their own separate process. This
will avoid impacting other manager resources.

To set up a separate process for reports, you must configure the server.properties file, and
then configure each report.

Project User's Guide
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1. Stop ESM Manager.

2. On the Manager host, update the file <ARCSIGHT_HOME>/config/server.properties
with this line:

report.canarchivereportinseparateprocess=true

3. Start the manager.
Separately, when configuring the reports, a new report parameter is made available in the Console.

1. In the Console, open the reports you are scheduling to run.

2. Right click Edit Report.

3. Select the Parameters tab.

4. Set Generate Report in Separate Process to true.

5. Click Apply to save changes.

For more information about archiving AID reports in a separate process, see the Knowledge Base
Article Archiving ESM Reports in a Separate Process, on the HPE support portal.

Installing Interactive Discovery
Log in to the Interactive Discovery target system with Administrator privileges; the installer makes
modifications to the registry.

1. Verify system requirements as found in the ADVIZOR Implementation Guide, located in the ZIP file
download in AID\Advizor.

2. Uninstall any previous version of ArcSight Interactive Discovery.

3. From the HP Software Support site (https://softwaresupport.hpe.com) download the Interactive
Discovery ZIP file (HP_ArcSight_Interactive_Discovery_6.4_AID.zip) using the log-in
credentials you received when you purchased ArcSight Interactive Discovery.

4. Extract the ZIP file (Note: by default, extract to C:\ to match default locations used in the .adv files
and guide examples.)

5. Browse to AID\Advizor. Depending on your system, launch either the 32-bit or 64-bit version of
ArcSight Interactive Discovery Bundle.exe.

6. Follow the instructions in the installation wizard to set up Interactive Discovery.

7. When the installation is complete, review the "What’s New" section of the online help for important
information regarding this release.

Project User's Guide
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Extracting the Other Zip Contents
When you unzip HP_ArcSight_Interactive_Discovery_6.4_AID.zip, it creates the following
layout:

When you extract the content files, the HP_ArcSight_Interactive_Discovery_6.4_AID.zip file
creates and writes the files to an AID subdirectory.

By default, extract to C:\ to match default locations used in the .adv files and guide examples.

Verify that all the files in the ZIP file were extracted.

After extracting the files, you can move and copy them using these guidelines:

l You can copy and rename ADV project files and put them wherever you want.

l You can copy and rename CSV files as necessary, provided there is a corresponding INI file with the
same name in the same folder.

l The "CONTENT" directory holds all the project and sample files. It is recommend that you do not
modify these sample files. Copy the AID\Content\ESM and AID\Content\Logger files to
the system where your ArcSight Console is installed.

l The "HP_Data_Analysis" directory is the working directory where you save your event files for
analysis and visualizaion.

l You can change the source file that a project uses and then save the project with a different name.
Source files are always CSV files.

Uninstalling Interactive Discovery
To uninstall Interactive Discovery:

1. In Windows, launch Control Panel.

2. Follow the steps for your version of Windows to uninstall the application.

To uninstall the AID content from the ESM Manager:

Project User's Guide
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1. Launch ArcSight Console.

2. In the Navigator panel, click the Packages tab.

3. Open the ArcSight Interactive Discovery group.

4. Right-click the ArcSight Interactive Discovery package and choose Uninstall Package.

To uninstall the AID fieldset content from Logger:

1. Launch Logger.

2. In the Search box, type fieldsets.

3. In the search results, locate the AID fieldset content to be deleted.

4. Click the X on the right side of the entry to delete the content.

To uninstall the AID report content from Logger:

1. Launch Logger.

2. Click Reports from the main menu.

3. Select Category Explorer.

4. Right click on ArcSight Interactive Discovery and select Delete.

5. Click Yes to confirm deletion.

Project User's Guide
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Chapter 3: Generating ESM Data
ArcSight Interactive Discovery operates on data exported from your daily event flow from ArcSight
focused reports, which filter and aggregate events into a schema that is ready to consume by Interactive
Discovery. This chapter describes the process of loading data from ESM into Interactive Discovery.

Interactive Discovery ships with a sample data set loaded into its default CSV files. You can use this data
set as a tutorial for getting familiar with the ArcSight Interactive Discovery projects and tools, as
outlined in chapters 4 and 5.

l "Overview: Data from ESM" below

l "ESM Focused Reports " on page 17

l "Running an ESM Focused Report" on page 18

l "Building a Focused Report" on page 18

l "Scheduling a Focused Report" on page 19

Overview: Data from ESM
Generating data for an Interactive Discovery project is a four-step process. These steps are outlined
below and detailed in the pages to follow.

1. Import the ESM Content files.

2. From the ArcSight Console, run one of the Interactive Discovery focused reports. You can run
them as needed or schedule them to run regularly.

3. Open the report output file and save it to C:\AID\HP_Data_Analysis\ESM\ AID_
Schema.csv.

You can specify any file name.

In addition, you must save an INI file with the same name as the CSV file. You can copy and rename
the CSV files that come with the ESM Content in HP_ArcSight_Interactive_Discovery_6.4_AID.zip.

4. If you have a separate Interactive Discovery system, copy the resulting CSV file there. The CSV and
its matching INI file can go in any folder.

5. Open the Interactive Discovery ADV project file ( ArcSight_AID_Schema.adv). When you open the
Interactive Discovery project you can point it to the appropriate data source. To change or add

data source files in Interactive Discovery, select File > Manage Data Sources..

To incorporate Interactive Discovery into your everyday operations, schedule one or more of the
Interactive Discovery focused reports to run once at a set time every day, and use their output to
analyze and build reports about the day's network security events. For instructions about how to
schedule reports, see the Console online help topic "Scheduling Tasks."
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Tip: Avoid scheduling more than one Interactive Discovery report to run at the same time.
Scheduling them to run at different times gives the file output names unique date/time stamps.

Importing the Interactive Discovery Package into
ESM
Use the ArcSight Console import capability to import the ArcSight Interactive Discovery.arb
content file found in C:\AID\Content\ESM, as described below.

1. Save the ArcSight_Interactive_Discovery.arb content file to a network location accessible
to your ArcSight Console.

2. Launch ArcSight Console.

3. In the Navigator panel, click the Packages tab.

4. Click Import, at the top of the Packages tab.

5. Access the ARB file and click the Open button.

6. On the Packages for Installation dialog, click Next.

7. ArcSight Console creates an ArcSight Interactive Discovery folder, as shown below.

To verify that installation was successful and the content is accessible in ESM:

1. In the Navigator panel, go to Filters and navigate to the ArcSight Interactive Discovery Filters
folder. Verify that the folder appears as shown below.

2. In the Navigator panel, go to Reports and navigate to All Reports. Verify that the the ArcSight
Interactive Discovery folder appears as shown below.

3. If you do not see these filters and reports, right-click in the Navigator panel and select Refresh.

Project User's Guide
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Note: Note that the reports shown above are focused reports. There is also a subfolder called
Templates containing AID_Schema base reports from which you can create other focused
reports.

See "Generating ESM Data" on page 15.

ESM Focused Reports
For ESM, Interactive Discovery includes the report templates listed in the following table. When
combined with the filters listed in the Filter table, they make ESM focused reports, which are listed in the
Focused Report table. Once installed, find these reports in the ArcSight Console Navigator’s Reports
resource:
/All Reports/ArcSight Interactive Discovery/Templates/.

Template Description

AID_
Schema
Schema

This report shows a selection of event fields useful for analyzing security data. It makes working in the
Explorer easier and consumes less space when transporting the data from the ESM Manager to the
Explorer.

The following filters are used by the Interactive Discovery focused reports to filter for the specific types
of events that you are interested in for your analysis. These filters are located in the ArcSight Console
Navigator’s Filters resource: /All Filters/ArcSight Interactive Discovery.

Filter Description

Attacks Exports traffic that resembles attacks.

Attacks
Targeting
Critical Servers

Exports traffic that indicates potential attacks against servers classified as Very High criticality in
/All Asset Categories/ System Asset Categories/Criticality/Very High.

Authentication
and
Authorization

Shows authentication and authorization events (logins, password changes, and so on).

Intrusion
Detection
Systems

Exports just intrusion detection system events.

Firewall Events Shows only firewall events.

Operating
System

Selects all operating system events (such as logon/off, resource failures, system reboot).

These reports and filters are combined as focused reports, which are located in the ArcSight Console

Navigator’s Reports resource: /All Reports/ArcSight Interactive Discovery…. All the
Interactive Discovery reports filter out ESM internal events (self-auditing events).
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Focused Report Description

All - AID_Schema Compiles all events (no filters applied) in the past 2 (by default) hours using the AID_
Schema of data.

Attacks - AID_Schema Compiles all events that involve attacks in the past 2 (by default) hours using the AID_
Schema of data.

Attacks Targeting Critical
Servers - AID_Schema

Compiles all events that targeted critical servers in the past 2 (by default) hours using
the AID_Schema.

Authentication and
Authorization - AID_Schema

Compiles all events classified as authentication and authorization events in the past 2
(by default) hours using the AID_Schema of data.

Firewall Events - AID_
Schema

Compiles all firewall events in the past 2 (by default) hours using the AID_Schema of
data.

IDS - AID_Schema Compiles all IDS events in the past 2 (by default) hours using the AID_Schema of data.

Operating System - AID_
Schema

Compiles all operating system events (such as resource failures and system reboot) in
the past 2 (by default) hours using the AID_Schema of data.

Running an ESM Focused Report
1. In the Navigator panel Reports resource tree, go to /All Reports/ArcSight Interactive Discovery.

2. Right-click the focused report you wish to run and select Run > Report with defaults.

3. The report will likely take several minutes to run, depending on how much data it has to process. As
the report runs, the message
[date, time] Creating report…Please wait…
is displayed in the Messages bar at the bottom of the Console. When the report is finished running,
the message
[date, time] Launching report in the browser window…
is displayed. Both of these processes may take several minutes. When the report is finished
running, it opens in a browser window with numbered lines in a grid format.

The report defaults are set to 100,000 lines of output and 2 hours. To increase these values, edit the

report (right-click the report's icon and choose Edit Report) and change the values as required.

NOTE: ArcSight has tested the reports to 100,000 and found acceptable performance. Increasing
the report parameters may require increasing ESM memory management parameters.

See "Save ESM Data to Interactive Discovery" on page 20

Building a Focused Report
In ESM, you can use one of the existing ArcSight Interactive Discovery template reports for building a
new focused report with your own specifications. The only report changes we encourage are changes in
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the filter conditions to select a specific set of events to be exported into Interactive Discovery.

To create a new focused report:

1. In the Navigator panel Reports resource tree, click on the Reports tab and go to /All
Reports/ArcSight Interactive Discovery/Templates….

2. Right-click AID_Schema report and select New Focused Report.

3. In the Focused Report Editor in the Inspect/Edit panel, select the Attributes tab and name the
report in a way that distinguishes it from its original.

4. Click the Parameters tab and change any of the values as appropriate. These values are the same
ones you set when running a new or archived Report.

5. Click Apply to make changes and keep the editor open.

6. Click OK to store the definition in the resource tree in the same folder as the original report and
close the editor.

Scheduling a Focused Report
You can schedule a focused report. Once the report has run, save it as AID_Schema.csv, and copy it to
the Interactive Discovery system, as described in"Save ESM Data to Interactive Discovery" on the next
page.

1. In the Reports resource tree, select the Report Definitions tab.

2. On the Reports tab, right-click the report you wish to schedule and select Schedule for archiving |
Report.

3. On the Jobs tab, click the Add button.

4. Enter a name under the Jobs field and a description for the report under the Description field.

If the reports you generate for a full day's events contain more than 100,000 lines, you should
modify the report to run in a shorter time frame, then schedule the report to run at those time
intervals throughout the day.

For example, if you set the report to run 6 hours worth of data, schedule the report to run at 6-
hour intervals, such as 12:00 a.m., 6:00 a.m., 12:00 p.m., and 6:00 p.m.

5. Select Click here to set up schedule frequency.

6. In the Job Frequency dialog, select your desired settings for job scheduling.

7. When the report has run, follow the instructions in Step 2: Save Report as "AID_Schema.csv" and
Copy to Interactive Discovery System as described in "Save ESM Data to Interactive Discovery" on
the next page.
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Save ESM Data to Interactive Discovery
1. After saving your report results as a CSV file, copy it to the Interactive Discovery system.

2. Make sure to save an INI file with the same name in the same folder. The ArcSight Interactive
Discovery project requires that its data source and INI files have the same name and be in the same
folder.

3. Navigate to All Archived Reports > ArcSight Interactive Discovery and find the report you just
ran. The report is marked with the date and time of last running, and the corresponding CSV file.

4. Save the file to the local Console system.

l If Interactive Discovery is installed on its own system, save the file to a location on the Console. By
default, reports are saved to $ARCSIGHT_HOME\current\tmp\reports, although you can
save the file to any directory.

l If Interactive Discovery is installed on the same system as ArcSight Console, save the file to the
folder where the other Inte.ractive Discovery files are located. For example: C:\AID\HP_
Data_Analysis\ESM

5. If Interactive Discovery is installed on its own system, copy the CSV file from the Console to the
Interactive Discovery system. The intent is that you place this file in the folder C:\AID\HP_Data_
Analysis\ESM, but the only two unbreakable rules are:

l The CSV file has to be in the same folder as the corresponding INI file (that is, with the same
name prefix).

l The appropriate Interactive Discovery project has to be looking for its data source in that folder.
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Chapter 4: Generating Logger Data
This chapter describes the process of generating data in Logger using a search or running a report and
sending it to Interactive Discovery.

Interactive Discovery ships with a sample data set loaded into its default CSV files. You can use this data
set as a tutorial for getting familiar with the ArcSight Interactive Discovery projects and tools.

This section includes the following topics

l "Overview: Logger Data" below

l "Using the Logger Search Method" on the next page

l "Using the Logger Report Method" on page 24

Overview: Logger Data
In Logger, there are two ways to generate data for Interactive Discovery: You can do a search using the
fieldsets provided or you can the report provided. The steps for each method are outlined below and
detailed in the pages to follow.

1. Generate data from a Logger search.

a. Import the Logger fieldset files.

b. Start a search and enter the search criteria.

c. Select one of the imported fieldsets.

d. Export the search to a CSV file.

2. Generate data from Logger reports.

a. Import the Logger report and the related queries provided in the CAB file.

b. Run the imported report.

c. Export the report results to a CSV file.

3. If you have a separate Interactive Discovery system, copy the resulting CSV file there. The CSV and
its matching INI file can go in any folder.

4. Open the Interactive Discovery ADV project file ( ArcSight_AID_Schema.adv). When you open the
Interactive Discovery project you can point it to the appropriate data source. To change or add

data source files in Interactive Discovery, select File > Manage Data Sources.
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Using the Logger Search Method
In this procedure you import the provided Logger fieldsets, run searches that use them, and export the
result as a CSV file. Then you save the CSV file as the data source for your Interactive Discovery project.

Importing the Interactive Discovery Package into Logger
The Logger content consists of two fieldsets and two reports. The first step is to import the fieldset
content, and then deploy the report content. Use the Logger import capability to import the Logger
fieldsets, as described below.

1. Save the logger fieldset file to a network location accessible to Logger.

2. Launch Logger.

3. In the Logger user interface, select Configuration > Import Content.

4. On the Import Content dialog, click Browse.

5. Browse to the fieldset to import and click Open.

6. On the Import Content dialog, click Import.

The fieldset file you imported is displayed.

7. Click Next.

8. To verify that the selected field sets was properly imported, click Configuration > Fieldsets and
verify that the fieldset you imported is displayed in the list.

9. Select the imported fieldset from the list.

10. To complete the update to the new field set, click Update now in the summary section in the lower-
left of the Logger window. This enables the field summary list to reflect the fields available in the
selected field set.
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11. A summary of the deploy results is displayed

12. Select Reports > Report Explorer to verify the report category and report were imported and
then run the reports to verify that they run correctly.

13. See "Generating Logger Data" on page 21.

Logger Fieldsets
For Logger, Interactive Discovery includes the following fieldsets. Once installed, find these fieldsets in
the Logger UI by clicking Configuration > Fieldsets.

Fieldset Description

AID_
Schema

This fieldset shows a selection of event fields useful for analyzing security data. It makes working in the
Explorer easier and consumes less space.

Run a Logger Search
In this procedure, you export the results of a Logger search as a CSV file, then open the CSV file in AID.

Refer to the Administrator's Guide for ArcSight Logger for details on how to export a search. The
general procedure is as follows:

1. In the Logger user interface, select Analyze > Search.

l Enter any search criteria whose results you want to analyze with Interactive Discovery and click Go.

3. Select one of the AID fieldsets from the Fieldset dropdown box. By default, All Fields is selected.

4. Click the Export down arrow to export the results to a file. Set these options:
a. Select Save to local disk.

b. Use the default format of CSV.

c. Do not check All Fields. It will use the fields in the fieldset.

5. Click Export.

6. Right-click on Download results to specify where to save the CSV file.
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To use the AID project included in the download (Logger_AID_Schema.adv) , specify the
CSV file name associated with that project.

If you want to build another AID project, specify a file name to help you identify it, and then create
another AID project to use that file.

7. Click Done.

8. If Interactive Discovery is installed on its own system, copy the CSV file from the Logger system to
the Interactive Discovery system. The intent is that you place this file in the folder C:\AID\HP_
Data_Analysis\Logger, but the only two unbreakable rules are:

l The CSV file has to be in the same folder as the appropriate AID_Schema INI file with the same
name prefix.

l The appropriate AID_Schema Interactive Discovery project has to be looking for its data source
in that folder.

Using the Logger Report Method
The Logger reports and their associated queries are bundled in CAB files. In this procedure you deploy
teach report bundle, run the report and export the result as a CSV file. Then you use the CSV file as the
data source for your Interactive Discovery project.

Import Logger Reports
Import the reports, bundled as a CAB file, as described below.

1. Select Reports > Deploy Report Bundle, under the Administration section.

2. On the Deploy Repository Bundle dialog, click Browse and select (open) the CAB file to be
imported and click Upload.

3. On the Deploy Repository Bundle dialog, click Deploy. 6. A summary of the deployment results is
displayed.

4. Go to Reports > Report Explorer to verify the report category and report were imported:

The report category is "ArcSight Interactive Discovery."
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Running the Logger Report
Use the following general procedure to run one of the Logger reports and save the results as a CSV file.
For details refer to the Logger Administrator's Guide for your version of Logger.

1. Select Reports > Report Explorer > ArcSight Interactive Discovery.

2. Select a report to run.

3. Click the Run Report option.

4. Click on the filter tab, if you want to limit the data to events where certain fields contain certain
values.

5. Click the Run button.

6. In the report parameters window you can select the start time. For example $Now - 1d for events
from the last two days until now.

7. Click Run Now.

8. When the report completes, select Save File. Logger saves the file as a CSV file.

9. If Interactive Discovery is installed on its own system, copy the CSV file from the Logger system to
the Interactive Discovery system. The intent is that you place this file in the folder C:\AID\HP_
Data_Analysis\Logger, but the only two unbreakable rules are:

l The CSV file has to be in the same folder as INI file with the same name prefix.

l The appropriate Interactive Discovery project has to be looking for its data source in that folder.
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Chapter 5: Open Project in Interactive
Discovery
Interactive Discovery ships with these projects:

l ArcSight_AID_Schema.adv

l Logger_AID_Schema.adv

ESM and Logger use different sets of fields. Each AID project makes use of product-specific data.

Which project file you open depends on what data you generated and from where.

1. On the Interactive Discovery system, launch Interactive Discovery. You can launch it by double-
clicking the ADV file. You can also select Open Project at the Getting Started screen and select
the appropriate project file.

2. Each ADV file remembers the absolute path to its associated data source file. When you first open a
project you might get a Locate Missing Data File dialog that reports the path of the file it cannot
find.

Use the browse button to navigate to the folder where the data source file is located and click OK.
(Make sure the INI file of the same name is present.)

If you had to browse to the file, select File > Save Project to preserve this location.

Interactive Discovery allows you to use a CSV file as a data source. A matching INI file in the same
folder is required.
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Chapter 6: Navigation Overview
Each Interactive Discovery project contains a set of tabs that enable you to analyze your network
security data using different interactive graphics.

Follow the instructions in "Open Project in Interactive Discovery" on page 27 to open a project. When the
project view opens, the window displays the Overview tab:

To familiarize yourself with Interactive Discovery's toolbars, click the Help icon (a red question mark)
and browse the topic "Interactive Discovery Toolbars."

You can toggle the toolbar for each individual chart or list panel by clicking the small triangle in the gray
bar beneath the panel, as shown below.

Click the arrows at the right end of the tab bar to scroll it left and right.

In most charts you can hover the cursor over a data point, (bar or pie slice, for example) to see details of
the data point.

The chart colors are from the event's priority as determined by the threat priority formula. To change
the color, use the Color by pull-down menu in the toolbar. For information on event priorities, see the
section in ESM 101 entitled, “Life Cycle of an Event through ESM."

To see the details of a chart element (bar, pie wedge, and so on), hover over it. You can also click on an

element to filter the view in all tabs. Right-click and select Select All to restore the views. Use the online
help for complete information on chart navigation.

Note that the sample data provided contains events where some of the values are NULL. In some cases,
values may have been removed for publication. Your results will be different.
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Chapter 7: Interactive Discovery AID_Schema
Project
The tabs provide multiple unique views of the data contained in this data set. Use the reports provided
in the package (the ARB file) to generate the data appropriate for the project.

The AID schema contains event fields that ArcSight considers the most common event criteria to
evaluate for most security situations and reduces the data to be processed.

The examples and visualizations here make use of data from the ESM project. Examples and
visualizations from Logger data will be slightly different from what is shown here.

Overview Tab
The Overview tab contains four charts.

l Aggregated Event Count per Priority: shows a pie chart of the number of events of each priority as
determined by the ArcSight priority formula.

l Aggregated Event Count per Device Product: shows the number of aggregated events by device
product (ArcSight, MS Windows, Unix, and so on).

l Aggregated Event Count by Time: shows the times when events occurred.

l Aggregated Event Count per Category Significance: Shows the number for each category of
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significance (hostile, normal, warning, and so on).

End Points Tab
The End Points tab contains three charts:

l Aggregated Event Count per Attacker Zone Name: Shows number of aggregated events that
occurred in various attacker IP address zones. You can use the right-click menu to drill down to
individual IP addresses.

l Aggregated Event Count per Target Zone Name: Shows number of aggregated events that
occurred in various target IP address zones. You can also right-click the menu to drill down to
individual IP addresses.

l Attacker/Target Address parabox: The parabox shows connections from the attacker to the
target. Select one of the bars in a bar chart on the left, and the parabox displays the connections
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involved with those events only. Bubble size indicates the amount of activity.

Ports Tab
The Ports tab contains two charts:

l Target Ports per Attacker Address: This scatter plot chart shows target ports on the left, attacker
addresses on the bottom. In this chart, you can look for conditions such as services running on ports
above 1024, which could warrant investigation, or you can exclude them from the view if they are not
significant. Multiple systems connecting to the same port appear as a horizontal line. Vertical lines
indicate one system connecting to multiple ports, which could indicate a port scan.

l Target Port: The right-hand scatter plot shows target ports on the y axis, time on the x axis. Over
time, you can recognize how users access services. You might see patterns where there are lines, then
a gap; something happened where no one was accessing port 80. That gap also is displayed in the
Overview page histogram. You can drill down here to see details.

Use the zoom tools at the corners to magnify elements in the view.
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Parabox Tab
The Parabox tab contains one large view that shows the various elements of an event as bubbles of
different sizes and colors. The size of the bubbles indicates the distribution of events: the larger the
bubble, the more activity is indicated.
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To investigate in the parabox:

1. Expand the pull-down menu at the bottom of the page to reveal data configuration tools.

2. Click on one node, such as Failure. All nodes involved with the failures remain selected.

3. Right-click in the parabox and select Exclude Unselected to remove unselected items.

4. Click the small gray arrow at the bottom of the display to toggle the toolbar on. Then, click the
Display axis of individual data cases button ( )to show the connections between the nodes.

This shows that port 22 is involved with most of the failures and it goes to similar target addresses:
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Categories Tab
The Categories tab gives you an idea of what's happening according to the ArcSight event categories.
To see the details of each category, hover over the bars. You can also use the individual bars on this tab
as a way to filter the rest of the views.

The Categories tab contains five charts.

l Aggregated Event Count per Category Object: For each category of objects (host, application,
service, and so on), it shows the number of aggregated events.

l Aggregated Event Count per Category Behavior: For each category of behaviors (access, add,
delete, execute, and so on), it shows the number of aggregated events.

l Aggregated Event Count per Category Technique: For each category of techniques (brute force,
scan, redirection, and so on), it shows the number of aggregated events.

l Aggregated Event Count per Category Device Group: For each category of device groups
(antivirus, firewall, operating system, and so on), it shows the number of aggregated events.

l Aggregated Event Count by Category Significance and Outcome: Shows the number of events
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by both significance and outcome.

Categories 2 Tab
The Categories 2 tab contains two more charts:

l Category Technique per End Time: shows events as they occur over time by their security
technique (brute force, scan, redirection, and so on).

l Category Significance per End Time: shows events as they occur over time, by their significance
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(hostile, normal, warning, and so on).

Events Tab
The Events tab contains one large scatter plot that shows all events in the data set over time. Use the
zoom tools in the corners to zoom in on patterns. Use the right-click menu to drill down to details. Use
this chart to look for holes, repeated activity, lines or significant gaps. Look for dominant lines or lack of
lines.
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Asset Categories Tab
The Asset Categories tab shows two charts.

l Aggregated Event Count per Criticality of Asset: Shows the percentage of events based on the
asset's criticality. Asset criticality is determined by the ArcSight priority formula.

l Aggregated Event Count per Business Role: Shows the percentage of events based on the asset's
business role. Business role is based on the asset categories set for the assets involved in these
events.

Mouse over the various sections for a description of their contents.
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Service Access Tab
The Service Access tab contains two charts:

l Attacker Address and Port: This graphic shows the attacker IP addresses and their relationship
with the ports involved in the subject events.

l Aggregated Event Count per Business Role pie chart: Shows the percentage of events based on
the asset's business role. Business role is based on the asset categories set for the assets involved in
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these events.

You can select target ports of interest, then see the business role of the events involved in the chart. For
example, if you click the large port 22 bubble, then click the Exclude Unselected button, you see the
attacker addresses and the business roles of the systems involved.

Customer Tab
The Customer tab contains two views:

l Aggregated Event Count per Customer Name: Shows a bar chart of all events associated with the
customers configured for this system.

l Customer Name timetable: Shows a timetable on the right showing all customers over time when
events are generated for these customers.

The example below is derived from sample data that contains no customer names. Your results may be
different.
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Business Role Investigation Tab
The Business Role Investigation tab contains four charts.

l Aggregated Event Count per Business Role: Shows the percentage of events based on the asset's
business role. Business role is based on the asset categories set for the assets involved in these
events.

l Aggregated Event Count per Category Significance: Shows aggregated events according to their
significance as determined by the ArcSight event categories.

l Attacker Address and Name List: Shows attacker IP address and event name.

l Aggregated Event Count per Category Outcome: Shows aggregated events classified as
successes, failures, and attempts.

Use the Business Role Investigation tab to map event outcomes to the business systems targeted. For
example, you would want to see only traffic categorized as Normal occurring on revenue-generating
systems. If there are any Compromise events, you can use this view to verify that they are not occurring
on a revenue-generating system. If there is a compromise occurring on a revenue generating system,
you can see the outcome of the event: attempt, failed, or success.

You can click the Success bar to select those events, then use the other views to see which systems were
involved.
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Services by Business Unit Tab
The Services by Business Unit tab contains three charts.

l Category Significance multiscape: Shows event counts by category significance and target port.

l Business Role and Category parabox: Shows the business role as it relates to category significance
and technique.

l Business Role and Target Port parabox: Shows the business role and the target port. Use these to
detect interactions, such as DOS attacks. For example, if you select a revenue-generating system, you
can see types of applications that were being used on these systems, which can give you insight into
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unauthorized use.
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Chapter 8: Interactive Discovery Use Cases
The data files shipped with ArcSight Interactive Discovery contain sample data you can use as a tutorial
to learn how to use ArcSight Interactive Discovery to discover new trends in your security data and
create effective reports. This chapter walks you through some use cases to demonstrate how to use the
Interactive Discovery exploratory tools and build a report.

l "Business Case for Interactive Discovery" below

l "Use Case 1: Explore Security Data on Port 23" on page 45

l "Use Case 2: Analyze Security Data from the Firewall" on page 46

l "Use Case 3: Export Pages to a Presentation" on page 53

Business Case for Interactive Discovery
Interactive Discovery enables you to present data you have collected about your network security
enterprise and tailor it to different audiences. For example, you can export Interactive Discovery pages
into web pages, PDF files, Microsoft Word documents, and PowerPoint presentation slides.

These additional features in this release assist you in those communications:

l The Flight Recorder

l Animation

l Data Export

The Flight Recorder
The Flight Recorder feature can be used to record all actions and selections taken in AID. It also
provides the following:

l A place to collect observations by adding notes.

l Playback of previously taken actions,either in the same session on the same data or in a later session
with updated data.

l Bookmarks, which may be reused in the future or shared with others.

To display the Flight Record, in the View menu, select Flight Recorder. (Flight Recorder is not
displayed by default.)

Most actions are recorder by Flight Recorder automatically. Recorded actions have a one-line summary.
Additional details can be displayed by toggling the gray arrow on the left.
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For more about Flight Recorder, see the AID product help.

The Flight Recorder greatly enhances the Bookmark functionality found in previous versions of the
product.

Animation
The animation feature enables you to visualize events in motion through time. You can choose the field
to animate on.

To view the animation toolbar, click View > Toolbars > Animate, and then choose the appropriate
fields from the drop-down lists.

For more information about animation, consult the AID product help.

Data Export
In the process of an investigation, you may want to export only the selected events in your project for
further analysis or evidence.

To export selected data,

1. Click File > Export Data.

2. On the Export Data dialog, select the Export Format.

3. Under Export Data, choose Selected.

4. Click OK.

About Selection Tools
Interactive Discovery enables you to select one or more elements in a chart.

l To select a single element, click once on the element.

l To select multiple elements, click and drag over the elements you wish to select.

l To mask out the other elements on the screen, right-click your selection and choose one of the
following options (or click the corresponding button in the toolbar):
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Option Description

Select all Clears all previous selections and restores all data to the .

Unselect all Unselects all data from the so you can choose the few you want.

Toggle Selection Switch between Select All and Unselect All s.

Exclude selected Removes the selected elements in the data .

Exclude Unselected Removes the unselected elements in the data .

Restore excluded Re-displays all excluded elements, whether they are selected or unselected.

Undo/ Redo
Click Undo to undo changes one at a time.
Click Redo to redo changes one at a time.

When you select an element in one chart, that element is selected in all the charts on all the pages.
Because each chart displays the data from a different perspective, this is how you can explore all the
properties related to a data element.

Use Case 1: Explore Security Data on Port 23
The first strategy you can use to investigate data is to click through the tabs.

Start with known vulnerabilities, such as traffic on port 23, the port used for telnet plain text traffic.
Passwords go through on this port in plain text, so no users should be using it. Services, however, often
use this port.

The Attacker Address and Port chart on the Service Access tab (from the AID_Schema project) shows
attacker addresses on one side and the target ports on the other. Click on port 23 to select only the
traffic targeting port 23. This highlights the traffic on port 23 in the other 13 tabs, which enables you to
explore:

l Which systems reported the events (Over, Parabox)

l What systems that traffic targets (End Points, Parabox, Service Access)

l The business unit of the systems involved (Services by Business Unit, Business Role investigation)

l The category outcome of the events, such as success, failure, attempt (Categories, Parabox)

l The category significance of events, such as normal, suspicious, hostile (Over, Categories, Parabox)
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Use Case 2: Analyze Security Data from the Firewall
One common security scenario to explore is firewall activity. (This use case is specific to the ESM project
only.)

1. On the Categories tab, go to Aggregated Event Count per Category Device Group.

2. Click on the Firewall bar of the bar chart to select all firewall events.
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3. Right-click the Firewall bar and select Exclude Unselected (or click the Exclude Unselected button
on the toolbar) to remove unrelated events.
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4. To see which events succeeded in passing packets through the firewall and which events failed
(were blocked by the firewall), go to the Color By drop-down menu in the toolbar and select Color
Scale by Priority and Color by: Category Outcome.

5. To see what the colors represent, select View > Color and Selection Legends from the top menu
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bar. Blue indicates failures (packets blocked by the firewall) and yellow indicates successes.

6. Click the End Points tab. The Attacker/Target Address chart on the right shows all the sources
and destinations involved in the firewall success and blocks. The attacker address 209.128.98.73
circled below has a fan of many blue lines, which indicates many failures on many different systems.
A pattern like this indicates potential malicious behavior.

The top attacker address, 199.248.65.119, connects to a few systems, and they were successes. The
combination of these two patterns indicates a system that tries and fails many times, and then has
successful connections on other targets. Because the same system has this pattern of failures, the
successes are suspect.

7. You can break down this further by selecting columns from the Aggregated Event Count per
Attacker Zone Name bar chart. Hold the shift key and click the two bars that contain blue:
198.20.0.0 - 222.255.255.255 and sj-arcnet-dmz. This shows which zones are
involved in the failed connection attempts.

8. Click one bar, then hold the shift key and click the other bar in the Aggregated Event Count per
Attacker Zone Name bar chart that contain failed connections (blue) to show which zones are
involved in the failed connections.
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9. Next, investigate which ports the malicious attacker address connected to. Click the malicious
attacker node to select just that activity. This highlights these connections in the other pages.

10. Click the Service Access tab. This shows the ports to which the malicious attacker has connected.
According to the data, it was using only one port on different systems. This indicates that it could
be a worm, which probes systems for the same port. On the other hand, if the target port that is
denying service requests is a web server, it may indicate a problem with the web server.

See below: The attacker was probing different systems for port 22.
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11. Click the Events tab. This shows all the event names over time. Here you look for gaps in activity.
This shows a significant gap in activity, which could indicate a serious problem.

12. Go back to the Service Access tab and click the Select All toolbar button ( ) to include everything
again. You may see other trends here, such as multiple port scans, which would be indicated by
several fans from the attacker address column to the target port column.
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You can take the same approach to investigate attacks: look at category significance and look for events
categorized as hostile.

Project User's Guide
Chapter 8: Interactive Discovery Use Cases

HPE ArcSight Interactive Discovery 6.4.2 Page 52 of 57



Use Case 3: Export Pages to a Presentation
Once you have created your pages and selected the events you are visualizing, you can re-order them
before exporting them to a web page, web archive, Adobe PDF file, Microsoft Word document, or
PowerPoint file as a presentation.

To export one or more pages to a presentation:

1. Click File | Export Pages.

2. In the Export Pages dialog, click Add...

3. In the Page Export dialog, select a page from the Pages drop-down list. Optionally, add a title and
description and click OK.

4. Continue adding pages as needed, or click Add All to add all pages to the export.

5. Under File Format, choose an output file format for the presentation.

6. Under Options, select Include Color Legend. The legend clearly communicates what the colors in
your presentation represent.

7. Click OK. The export is saved and a message is displayed confirming the presentation save.
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Appendix A: AID_Schema
This appendix lists the event fields contained in the ESM and Logger schemas. Fields present in each
AID schema are indicated by “Yes” in the corresponding columns.

The Logger schema also includes a field called Non-cef Raw Message which is automatically added
during an export. It cannot be manually added or selected.

For a description of the ESM event groups, see ArcSight 101, chapter 3, “ArcSight Event Schema.”

Event Group Event Field Type
ESM
AID_Schema

Logger
AID_Schema

Event (root) Aggregated Event Count Integer Yes

Application Protocol Text Yes

Base Event Count Yes

Bytes In Integer Yes

Bytes Out Integer Yes

Correlated Event Count Integer Yes

Customer Name Text Yes

End Time DateTime Yes

Event Time Yes

External ID Yes

Logger Yes

Name Text Yes Yes

Transport Protocol Text Yes Yes

Vulnerability Name Text Yes

Attacker Attacker Address Text Yes

Attacker Geo Latitude Double Yes

Attacker Geo Longitude Double Yes

Attacker Port Integer Yes

Attacker Zone Name Text Yes
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Event Group Event Field Type
ESM
AID_Schema

Logger
AID_Schema

Category Category Behavior Text Yes Yes

Category Device Group Text Yes Yes

Category Object Text Yes Yes

Category Outcome Text Yes Yes

Category Significance Text Yes Yes

Category Technique Text Yes Yes

Device Device Action Text Yes

Device Address Text Yes

Device Event Class ID Text Yes

Device Product Text Yes Yes

Device Vendor Text Yes Yes

Device Version Text Yes

Device Zone Name Text Yes

File File Name Text Yes

Request URL Text Yes

Target Target Address Text Yes

Target Geo Latitude Double Yes

Target Geo Longitude Double Yes

Target Port Integer Yes

Target Zone Name Text Yes

Threat Priority Integer Yes Yes

Relevance Integer Yes

Severity Integer Yes

Criticality of Asset Text Yes

Business Role Text Yes

Source Source Address Text Yes

Source Host Name Text Yes

Source Port Integer Yes

Project User's Guide
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Event Group Event Field Type
ESM
AID_Schema

Logger
AID_Schema

Source Translated Address Text Yes

Source User ID Text Yes

Source User Name Text Yes

Source Zone Name Text Yes

Source Zone URI Text Yes

Destination Destination Address Text Yes

Destination Dns Domain Text Yes

Destination Host Name Text Yes

Destination Port Text Yes

Destination Translated
Address

Text Yes

Destination User ID Text Yes

Destination User Name Text Yes

Destination Zone Name Text Yes

Destination Zone URI Text Yes

Project User's Guide
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Send Documentation Feedback
If you have comments about this document, you can contact the documentation team by email. If an
email client is configured on this system, click the link above and an email window opens with the
following information in the subject line:

Feedback on Project User's Guide (ArcSight Interactive Discovery 6.4.2)

Just add your feedback to the email and click send.

If no email client is available, copy the information above to a new message in a web mail client, and send
your feedback to arc-doc@hpe.com.

We appreciate your feedback!
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